OK論壇

 找回密碼
 註冊
查看: 145|回復: 8

使用坐騎用韁繩後沒有增加移動速度

[複製鏈接]

1333

主題

0

聽眾

1萬

積分

高級會員

Rank: 9Rank: 9Rank: 9Rank: 9Rank: 9

  • TA的每日心情

    昨天 08:43 AM
  • 簽到天數: 253 天

    連續簽到: 4 天

    [LV.8]以壇為家I

    發表於 2017-9-4 18:46:34 |顯示全部樓層
    EA
    私服版號: rAthenaCN_v1.6.5
    問題內容: 其他問題
    本帖最後由 poro0122 於 2017-9-6 02:44 PM 編輯

    各位前輩.壇友們安好.

    在遊戲內使用坐騎用韁繩有成功顯示坐騎樣式,但沒有移動速度增加的感覺

    這是item_db中坐騎用韁繩的語法:
    1. 12622,Boarding_Halter,坐騎用韁繩,11,0,,0,,,,,0xFFFFFFFF,63,2,,,,,,{ setmounting(); },{},{ if (ismounting()) setmounting(); }
    複製代碼
    在GOOGLE瀏覽器搜尋了坐騎相關的關鍵字只有"無法顯示坐騎樣式",以及"使用坐騎用韁繩後會石化"的問題

    想詢問一下有人有發生過和我目前現在的困境嗎

    我該朝哪個方向修改才能使使用坐騎用韁繩後有移動速度增加的感覺..

    另外也有使用過"bonus bSpeedRate","bonus bSpeedAddRate"這兩個也無法有增加移動速度的感覺orz..
    回復

    使用道具 舉報

    3

    主題

    0

    聽眾

    3638

    積分

    中級會員

    Rank: 6Rank: 6

  • TA的每日心情
    奮斗
    5 天前
  • 簽到天數: 581 天

    連續簽到: 1 天

    [LV.9]以壇為家II

    發表於 2017-9-4 19:36:08 |顯示全部樓層
    player.conf
    // 玩家使用坐騎後的移動速度增加的量
    // 預設為25,100 = 100%的速度提升
    // How much should rental mounts increase a player's movement speed?
    // Default is 25. 100 = 100% Increase.
    rental_mount_speed_boost: 100

    這?
    回復

    使用道具 舉報

    1333

    主題

    0

    聽眾

    1萬

    積分

    高級會員

    Rank: 9Rank: 9Rank: 9Rank: 9Rank: 9

  • TA的每日心情

    昨天 08:43 AM
  • 簽到天數: 253 天

    連續簽到: 4 天

    [LV.8]以壇為家I

    發表於 2017-9-5 02:19:33 |顯示全部樓層
    LOVE770825 發表於 2017-9-4 07:36 PM
    player.conf
    // 玩家使用坐騎後的移動速度增加的量
    // 預設為25,100 = 100%的速度提升

    您好,首先先感謝您提醒這一塊的部份,是我疏忽沒有發現到這裡有相關坐騎設定.

    但是我將rental_mount_speed_boost: 分次輸入測試100,300,500,1000(普帳.G帳測試)

    使用坐騎用韁繩依然沒有速度增加的感覺

    在此也先和您說聲抱歉..我對錄影這方面不太懂,無法實際拍片測試給您看



    回復

    使用道具 舉報

    3

    主題

    0

    聽眾

    3638

    積分

    中級會員

    Rank: 6Rank: 6

  • TA的每日心情
    奮斗
    5 天前
  • 簽到天數: 581 天

    連續簽到: 1 天

    [LV.9]以壇為家II

    發表於 2017-9-5 23:06:42 |顯示全部樓層
    本帖最後由 LOVE770825 於 2017-9-5 11:14 PM 編輯
    poro0122 發表於 2017-9-5 02:19 AM
    您好,首先先感謝您提醒這一塊的部份,是我疏忽沒有發現到這裡有相關坐騎設定.

    但是我將rental_mount_sp ...

    rAthenaCN_v1.7.3 最新版本


    這是我內建的寫法,你試試
    1. 12622,Boarding_Halter,坐騎用韁繩,11,0,,0,,,,,0xFFFFFFFF,63,2,,,,,,{ sc_start SC_ALL_RIDING,-1,1; },{},{}
    複製代碼
    這是舊版的↑

    這是新版的↓
    1. 12622,Boarding_Halter,坐騎用韁繩,11,0,,0,,,,,0xFFFFFFFF,63,2,,,,,,{ setmounting(); },{},{ if (ismounting()) setmounting(); }
    複製代碼
    回復

    使用道具 舉報

    1333

    主題

    0

    聽眾

    1萬

    積分

    高級會員

    Rank: 9Rank: 9Rank: 9Rank: 9Rank: 9

  • TA的每日心情

    昨天 08:43 AM
  • 簽到天數: 253 天

    連續簽到: 4 天

    [LV.8]以壇為家I

    發表於 2017-9-6 09:25:42 |顯示全部樓層
    LOVE770825 發表於 2017-9-5 11:06 PM
    rAthenaCN_v1.7.3 最新版本

    您好,再次感謝您為了我的這個問題又熱心的回覆我

    我將item_db坐騎用韁繩換成↓後,也是沒有移動速度增加的感覺...
    1. 12622,Boarding_Halter,坐騎用韁繩,11,0,,0,,,,,0xFFFFFFFF,63,2,,,,,,{ sc_start SC_ALL_RIDING,-1,1; },{},{}
    複製代碼
    我是有試過利用腳本GM指令來讓坐騎用韁繩使用後有移動速度增加的感覺

    腳本:
    1. function        script        LOAAC        {

    2. atcommand "@speed 0";
    3. end;
    4. }
    複製代碼
    只是如果是用這樣達到移動速度增加的話,我該如何讓角色卸下坐騎的同時也恢復正常移動速度...?
    回復

    使用道具 舉報

    0

    主題

    0

    聽眾

    1037

    積分

    普通會員

    Rank: 3Rank: 3Rank: 3

  • TA的每日心情
    無聊
    昨天 10:45 PM
  • 簽到天數: 91 天

    連續簽到: 1 天

    [LV.6]常住居民II

    發表於 2017-9-6 12:02:12 |顯示全部樓層
    本帖最後由 bycc 於 2017-9-6 12:19 PM 編輯

    poro0122 發表於 2017-9-6 09:25 AM
    您好,再次感謝您為了我的這個問題又熱心的回覆我

    我將item_db坐騎用韁繩換成↓後,也是沒有移動速度增加 ...
    1. 12622,Boarding_Halter,Reins Of Mount,11,0,,0,,,,,0xFFFFFFFF,63,2,,,,,,{ setmounting(); if ( [email protected] ) { @a=1; atcommand "@speed 0"; } else{ @a=0; atcommand "@speed 150";}},{ },{ if (ismounting()) setmounting(); }
    複製代碼
    試試看. 不是好方法但可以用QQ
    已有 1 人評分積分 現金 積極性 收起 理由
    louis8604031 + 20 + 20 + 20 我很贊同

    總評分: 積分 + 20  現金 + 20  積極性 + 20   查看全部評分

    回復

    使用道具 舉報

    1333

    主題

    0

    聽眾

    1萬

    積分

    高級會員

    Rank: 9Rank: 9Rank: 9Rank: 9Rank: 9

  • TA的每日心情

    昨天 08:43 AM
  • 簽到天數: 253 天

    連續簽到: 4 天

    [LV.8]以壇為家I

    發表於 2017-9-6 14:37:49 |顯示全部樓層
    bycc 發表於 2017-9-6 12:02 PM
    poro0122 發表於 2017-9-6 09:25 AM
    您好,再次感謝您為了我的這個問題又熱心的回覆我

    您好,首先先和您說聲萬分感謝..

    1. { setmounting(); if ( [email protected] ) { @a=1; atcommand "@speed 0"; } else{ @a=0; atcommand "@speed 150";}},{ },{ if (ismounting()) setmounting(); }
    複製代碼
    打上後

    使用坐騎移動速度有增加了,並且卸下坐騎移動速度也恢復正常

    這樣一來我的坐騎再也不只是裝飾用了XDD

    感謝感謝再感謝~~~
    回復

    使用道具 舉報

    1333

    主題

    0

    聽眾

    1萬

    積分

    高級會員

    Rank: 9Rank: 9Rank: 9Rank: 9Rank: 9

  • TA的每日心情

    昨天 08:43 AM
  • 簽到天數: 253 天

    連續簽到: 4 天

    [LV.8]以壇為家I

    發表於 2017-9-6 14:43:05 |顯示全部樓層
    如果今後有人和我發生一樣情形,那希望此篇能夠幫助到您~~

    解決方法:

    (1).#2 @LOVE770825 前輩提出的
    conf/battle/player.conf
    // 玩家使用坐騎後的移動速度增加的量
    // 預設為25,100 = 100%的速度提升
    // How much should rental mounts increase a player's movement speed?
    // Default is 25. 100 = 100% Increase.
    rental_mount_speed_boost: 100

    (2). #6 @bycc 前輩提出的
    1. 12622,Boarding_Halter,Reins Of Mount,11,0,,0,,,,,0xFFFFFFFF,63,2,,,,,,{ setmounting(); if ( [email protected] ) { @a=1; atcommand "@speed 0"; } else{ @a=0; atcommand "@speed 150";}},{ },{ if (ismounting()) setmounting(); }
    複製代碼
    雖然不知道為什麼(1)的方法我修改了沒反應,但我想應該是自己的問題吧

    我是用(2)的方法,讓此情形解決的

    在此感謝兩位前輩出手相助 感謝~~
    回復

    使用道具 舉報

    278

    主題

    3

    聽眾

    4萬

    積分

    上位版主

    ???

    Rank: 39Rank: 39Rank: 39Rank: 39Rank: 39Rank: 39Rank: 39

  • TA的每日心情
    開心
    昨天 12:20 AM
  • 簽到天數: 763 天

    連續簽到: 17 天

    [LV.10]以壇為家III

    宣傳大使 在線長老

    發表於 2017-9-6 15:47:46 |顯示全部樓層
    poro0122 發表於 2017-9-6 02:43 PM
    如果今後有人和我發生一樣情形,那希望此篇能夠幫助到您~~

    解決方法:

    雖然腳本可以解決這個問題
    但還是建議回報給RaCN開發者

    回復

    使用道具 舉報

    您需要登錄後才可以回帖 登錄 | 註冊

    手機版|Archiver|OK討論區  

    GMT+8, 2017-9-27 12:11 AM , Processed in 0.099378 second(s), 29 queries , Gzip On.

    Powered by Discuz! X2.5

    © 2001-2012 Comsenz Inc.

    回頂部